Jump to content
  • 0
Sign in to follow this  
Rhiannon

Acis - Problema no Gameserver

Question

Boa noite!

Eu tenho um servidor rodando na minha casa e meus amigos todos conseguem entrar e jogar, apenas eu não consigo!

Eu consigo criar minha conta, o console registra que a conta foi criada, mas eu não consigo passar da tela de seleção de server!
Se pessoas de fora, até de outros países conseguem logar, então o problema não é na configuração do servidor eu imagino.

Ja faz mais de uma semana que to buscando como resolver, ja testei um milhão de coisas e nada funciona.

Meu l2.ini está exatamente igual ao dos meus amigos, pois estamos usando o mesmo patch.
O unico jeito que eu consigo logar é se rodo o server em modo local usando 127.0.0.1. Aí eu entro mas em modo offline, o que não adianta nada.

Eu uso No-IP, e em ambas (server.properties/loginserver.properties) configs estou usando a url do no-ip. Como eu disse, se outras pesoas conseguem entrar então está tudo certo as configs.

Espero que alguém tenha conseguido resolver e possa ajudar!

Edited by Rhiannon

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
17 horas atrás, Rhiannon disse:

Boa noite!

Eu tenho um servidor rodando na minha casa e meus amigos todos conseguem entrar e jogar, apenas eu não consigo!

Eu consigo criar minha conta, o console registra que a conta foi criada, mas eu não consigo passar da tela de seleção de server!
Se pessoas de fora, até de outros países conseguem logar, então o problema não é na configuração do servidor eu imagino.

Ja faz mais de uma semana que to buscando como resolver, ja testei um milhão de coisas e nada funciona.

Meu l2.ini está exatamente igual ao dos meus amigos, pois estamos usando o mesmo patch.
O unico jeito que eu consigo logar é se rodo o server em modo local usando 127.0.0.1. Aí eu entro mas em modo offline, o que não adianta nada.

Eu uso No-IP, e em ambas (server.properties/loginserver.properties) configs estou usando a url do no-ip. Como eu disse, se outras pesoas conseguem entrar então está tudo certo as configs.

Espero que alguém tenha conseguido resolver e possa ajudar!

problema resolvido!

Share this post


Link to post
Share on other sites
  • 0
Just now, Christian-SDM said:

problema resolvido!

Obrigado Christian!
Pessoal, o problema estava nas configs, numa parte que não estamos acostumados a editar.
 

#=============================================================
#                         Loginserver
#=============================================================

# This is transmitted to the clients, so it has to be an IP or resolvable hostname 
Hostname = cucol2.ddns.net

# Bind ip of the LoginServer, use * to bind on all available IPs
LoginserverHostname = 0.0.0.0
LoginserverPort = 2106

# The Loginserver host and port.
LoginHostname = 127.0.0.1
LoginPort = 9014

Vejam que ele editou o "LoginserverHostname = "
Antes estava como padrão, com o asterisco: LoginserverHostname = *
E foi mudado para 0.0.0.0
Tem que fazer a mesma coisa com o Gameserver:
 

# ================================================================
#                          Gameserver setting
# ================================================================

# This is transmitted to the clients, so it has to be an IP or resolvable hostname. If this ip is resolvable by Login just leave 
#* 
Hostname = cucol2.ddns.net

# Bind ip of the gameserver, use * to bind on all available IPs. QUANDO FOR PARA DEDICADO, DEIXAR COMO *
GameserverHostname = 0.0.0.0
GameserverPort = 7777

# The Loginserver host and port.
LoginHost = 127.0.0.1
LoginPort = 9014

Com essas mudanças eu rodo o server da minha casa, e consigo entrar junto com meus amigos. A diferença tbm é que o meu l2.ini fica com 127.0.0.1 e para meus amigos fica com o endereço do No-ip.

Muitíssimo Obrigado ao Christian-SDM!

  • I love it 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  


⭐ Links Úteis




⚔️ Server Patrocinador



🎁 Ofertas







×
×
  • Create New...